import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+)\\s(\\d+)(.*(?:\\r?\\n(?!\\w+\\s\\d).*)*)";
final String string = "Abc 123 def\n"
+ "ghi\n"
+ "jkl\n"
+ "Abc 123 def ghi jkl mno\n"
+ "Abc 123 def ghi jkl \n"
+ "mno";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}