package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?<ID>[2-9]{1}[0-9]{3}\s?[0-9]{4}\s?[0-9]{4}\s?)(?&ID){20,})`)
var str = `2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}