re = /((?<ID>[2-9]{1}[0-9]{3}\s?[0-9]{4}\s?[0-9]{4}\s?)(?&ID){20,})/m
str = '2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end