$re = '/((?<ID>[2-9]{1}[0-9]{3}\s?[0-9]{4}\s?[0-9]{4}\s?)(?&ID){20,})/m';
$str = '2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);