// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?<ID>[2-9]{1}[0-9]{3}\s?[0-9]{4}\s?[0-9]{4}\s?)(?&ID){20,})").unwrap();
let string = "2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 2453 1234 4367 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}