using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^\s<>@]+@[^\s<>@]+\.[^\s<>@]+)>";
string input = @"Some Name <emai1@email.com>; Some Name2 <emai2@email.com>; Some Name 3 <emai3@email.com>; Some Name 4 <emai4@email.com>;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}