const regex = /<([^\s<>@]+@[^\s<>@]+\.[^\s<>@]+)>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([^\\s<>@]+@[^\\s<>@]+\\.[^\\s<>@]+)>', 'gm')
const str = `Some Name <emai1@email.com>; Some Name2 <emai2@email.com>; Some Name 3 <emai3@email.com>; Some Name 4 <emai4@email.com>;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}