// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<([^\s<>@]+@[^\s<>@]+\.[^\s<>@]+)>").unwrap();
let string = "Some Name <emai1@email.com>; Some Name2 <emai2@email.com>; Some Name 3 <emai3@email.com>; Some Name 4 <emai4@email.com>;
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}