re = /<([^\s<>@]+@[^\s<>@]+\.[^\s<>@]+)>/m
str = 'Some Name <emai1@email.com>; Some Name2 <emai2@email.com>; Some Name 3 <emai3@email.com>; Some Name 4 <emai4@email.com>;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end