#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<street>[\S ]+?)\s*(?<number>\d+\s*[a-zA-Z]*\s*([-\/]\s*\d*\s*\w?\s*)*)$"
Local $sString = "Wittenberger Straße 9221" & @CRLF & _
"Wittenberger Str. 92" & @CRLF & _
"Straße des 17. Juni 122a" & @CRLF & _
"Straße des 17 Juni 122a" & @CRLF & _
"Str. 545 3" & @CRLF & _
"Dr.-Külz-Ring 13" & @CRLF & _
"Kanalstraße 13 /1" & @CRLF & _
"Prager Str. 3 a" & @CRLF & _
"Prager Str. 3a" & @CRLF & _
"Prager Str. 3 asd" & @CRLF & _
"Erika-Mann-Straße 61 - 61s" & @CRLF & _
"Erik-Mann-Straße 61 - 62 " & @CRLF & _
"Erika-Mann-Straße 61 -62" & @CRLF & _
"Erika-Mann-Straße 61b-61c-23d" & @CRLF & _
"Erika-Mann-Straße 61b/61c/23d/61b/61c/23d" & @CRLF & _
"dsaASa" & @CRLF & _
"" & @CRLF & _
"III. Tongraben5" & @CRLF & _
"3. Tongrabe 5" & @CRLF & _
"55er Str. 5" & @CRLF & _
"%§$§§ 2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")