# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<street>[\S ]+?)\s*(?<number>\d+\s*[a-zA-Z]*\s*([-\/]\s*\d*\s*\w?\s*)*)$"
test_str = ("Wittenberger Straße 9221\n"
"Wittenberger Str. 92\n"
"Straße des 17. Juni 122a\n"
"Straße des 17 Juni 122a\n"
"Str. 545 3\n"
"Dr.-Külz-Ring 13\n"
"Kanalstraße 13 /1\n"
"Prager Str. 3 a\n"
"Prager Str. 3a\n"
"Prager Str. 3 asd\n"
"Erika-Mann-Straße 61 - 61s\n"
"Erik-Mann-Straße 61 - 62 \n"
"Erika-Mann-Straße 61 -62\n"
"Erika-Mann-Straße 61b-61c-23d\n"
"Erika-Mann-Straße 61b/61c/23d/61b/61c/23d\n"
"dsaASa\n\n"
"III. Tongraben5\n"
"3. Tongrabe 5\n"
"55er Str. 5\n"
"%§$§§ 2\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.