$re = '/(?<street>[\S ]+?)\s*(?<number>\d+\s*[a-zA-Z]*\s*([-\/]\s*\d*\s*\w?\s*)*)$/m';
$str = 'Wittenberger Straße 9221
Wittenberger Str. 92
Straße des 17. Juni 122a
Straße des 17 Juni 122a
Str. 545 3
Dr.-Külz-Ring 13
Kanalstraße 13 /1
Prager Str. 3 a
Prager Str. 3a
Prager Str. 3 asd
Erika-Mann-Straße 61 - 61s
Erik-Mann-Straße 61 - 62
Erika-Mann-Straße 61 -62
Erika-Mann-Straße 61b-61c-23d
Erika-Mann-Straße 61b/61c/23d/61b/61c/23d
dsaASa
III. Tongraben5
3. Tongrabe 5
55er Str. 5
%§$§§ 2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);