# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/co[a-zA-Z]e/1/g;t' <<< "codexxccope
code"