package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`co[a-zA-Z]e`)
var str = `codexxccope
code`
var substitution = "1"
fmt.Println(re.ReplaceAllString(str, substitution))
}