use strict;
my $str = 'codexxccope
code';
my $regex = qr/co[a-zA-Z]e/p;
my $subst = '1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";