#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<='https:\/\/static\.example\.com\/gallery\/)(.*?)(\..*?)(?=')"
Local $sString = "...some code...<img data-src='https://static.example.com/gallery/image.jpg'>...some code..."
Local $sSubst = "$1.webp"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)