import re
regex = re.compile(r"(?<='https:\/\/static\.example\.com\/gallery\/)(.*?)(\..*?)(?=')", flags=re.MULTILINE)
test_str = "...some code...<img data-src='https://static.example.com/gallery/image.jpg'>...some code..."
subst = "$1.webp"
result = regex.sub(subst, test_str)
if result:
print(result)