$re = '/(?<=\'https:\/\/static\.example\.com\/gallery\/)(.*?)(\..*?)(?=\')/m';
$str = '...some code...<img data-src=\'https://static.example.com/gallery/image.jpg\'>...some code...';
$subst = "$1.webp";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;