import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<='https:\\/\\/static\\.example\\.com\\/gallery\\/)(.*?)(\\..*?)(?=')";
final String string = "...some code...<img data-src='https://static.example.com/gallery/image.jpg'>...some code...";
final String subst = "$1.webp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}