import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Z]{2}-?[A-Z]{2}-?\\d{2}|[A-Z]{2}-?\\d{2}-?\\d{2})$";
final String string = "AB-CD-12\n"
+ "AB-12-34\n"
+ "ABCD12\n"
+ "AB1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}