re = /^(?:[A-Z]{2}-?[A-Z]{2}-?\d{2}|[A-Z]{2}-?\d{2}-?\d{2})$/m
str = 'AB-CD-12
AB-12-34
ABCD12
AB1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end