// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[A-Z]{2}-?[A-Z]{2}-?\d{2}|[A-Z]{2}-?\d{2}-?\d{2})$").unwrap();
let string = "AB-CD-12
AB-12-34
ABCD12
AB1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}