$re = '/^(?:[A-Z]{2}-?[A-Z]{2}-?\d{2}|[A-Z]{2}-?\d{2}-?\d{2})$/m';
$str = 'AB-CD-12
AB-12-34
ABCD12
AB1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);