using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\s)http\S+";
string input = @"Test https://example.com/1234567890/ Test https://example.com/subdomain/subdomain2 Test https://example.com/domain";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}