$re = '/(?:^|\s)http\S+/';
$str = 'Test https://example.com/1234567890/ Test https://example.com/subdomain/subdomain2 Test https://example.com/domain';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);