const regex = /(?:^|\s)http\S+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)http\\S+', 'g')
const str = `Test https://example.com/1234567890/ Test https://example.com/subdomain/subdomain2 Test https://example.com/domain`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}