re = /(?:^|\s)http\S+/
str = 'Test https://example.com/1234567890/ Test https://example.com/subdomain/subdomain2 Test https://example.com/domain'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end