# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(,\s)|\\r|\\n/, /gm;t' <<< "./homework2 3,phone3,desc3,brand4\n4,phone4,desc4,brand4\n5,phone5,desc5,brand5"