import Foundation
let pattern = #"(,\s)|\\r|\\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"./homework2 3,phone3,desc3,brand4\n4,phone4,desc4,brand4\n5,phone5,desc5,brand5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #", "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)