$re = '/(,\s)|\\\\r|\\\\n/m';
$str = './homework2 3,phone3,desc3,brand4\\n4,phone4,desc4,brand4\\n5,phone5,desc5,brand5';
$subst = ", ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;