#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<=^).{1,50}(?:\n|$)|.{1,50}(?:\n|$)|.{1,50}"
Local $sString = "I wish to split" & @CRLF & _
" a long text into chunks" & @CRLF & _
" of nn chars max." & @CRLF & _
"To take as much chars as I can in each" & @CRLF & _
" chunk but importantly I want to finish each" & @CRLF & _
" chunk in a" & @CRLF & _
" linebreak " & @CRLF & _
"inorder to" & @CRLF & _
" avoid word split in the middle." & @CRLF & _
"If there was no single linebreak in all of the nn chars, ... split a word to 2 chunks." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")