using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^).{1,50}(?:\n|$)|.{1,50}(?:\n|$)|.{1,50}";
string input = @"I wish to split
a long text into chunks
of nn chars max.
To take as much chars as I can in each
chunk but importantly I want to finish each
chunk in a
linebreak
inorder to
avoid word split in the middle.
If there was no single linebreak in all of the nn chars, ... split a word to 2 chunks.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}