re = /(?<=^).{1,50}(?:\n|$)|.{1,50}(?:\n|$)|.{1,50}/m
str = 'I wish to split
a long text into chunks
of nn chars max.
To take as much chars as I can in each
chunk but importantly I want to finish each
chunk in a
linebreak
inorder to
avoid word split in the middle.
If there was no single linebreak in all of the nn chars, ... split a word to 2 chunks.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end