#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\[url=[^]'\r\n]+](.+?)\[/url\]"
Local $sString = "[url=goo'gle.co.uk]A RANDOM LINK[/url]," & @CRLF & _
"[url=google.co.uk]A RANDOM LINK[/url]," & @CRLF & _
"[url=google.co.uk]A RANDOM LINK[/url],"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")