re = /\[url=[^]'\r\n]+](.+?)\[\/url\]/m
str = '[url=goo\'gle.co.uk]A RANDOM LINK[/url],
[url=google.co.uk]A RANDOM LINK[/url],
[url=google.co.uk]A RANDOM LINK[/url],'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end