package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\[url=[^]'\r\n]+](.+?)\[/url\]`)
var str = `[url=goo'gle.co.uk]A RANDOM LINK[/url],
[url=google.co.uk]A RANDOM LINK[/url],
[url=google.co.uk]A RANDOM LINK[/url],`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}