$re = '~\[url=[^]\'\r\n]+](.+?)\[/url\]~ms';
$str = '[url=goo\'gle.co.uk]A RANDOM LINK[/url],
[url=google.co.uk]A RANDOM LINK[/url],
[url=google.co.uk]A RANDOM LINK[/url],';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);