#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<dup>(\w+\s+))(?P=dup)"
Local $sString = "#命名表达式,并反向引用。比如查找重词" & @CRLF & _
"1 hello hello " & @CRLF & _
"2 hello world" & @CRLF & _
"3 妮妮好" & @CRLF & _
"4 你 你 " & @CRLF & _
"5 wo wo " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")