// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<dup>(\w+\s+))(?P=dup)").unwrap();
let string = "#命名表达式,并反向引用。比如查找重词
1 hello hello
2 hello world
3 妮妮好
4 你 你
5 wo wo
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}