$re = '/(\G(?!^|(?:[0-9A-Za-z][^0-9A-Za-z]*){2}$)|^(?:[^0-9A-Za-z]*[0-9A-Za-z]){5})./m';
$str = 'A1../D//FASDFAS--DFASD//.F';
$subst = "$1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;