const regex = /(?<!BM\.)(?<=\W)Draw(Image|Text)\s*([^\;\n]+)(\;|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!BM\\.)(?<=\\W)Draw(Image|Text)\\s*([^\\;\\n]+)(\\;|$)', 'gm')
const str = ` BM.DrawImage(GameOverImg,MW-ImageWidth(GameOverImg) , MH-ImageHeight(GameOverImg));
gotxt=GetTextLine(60);
break;
case 0: // если пориграли
BM.SetColor(255,0,0);
DrawImage GameOverImg,MW-ImageWidth(GameOverImg) , MH-ImageHeight(GameOverImg);
DrawText string gotxt,MW-TextWidth(gotxt)/2 , MH-TextHeight(gotxt)/2`;
const subst = `BM.Draw$1($2)$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);