import re
regex = re.compile(r"(?<!BM\.)(?<=\W)Draw(Image|Text)\s*([^\;\n]+)(\;|$)", flags=re.MULTILINE)
test_str = (" BM.DrawImage(GameOverImg,MW-ImageWidth(GameOverImg) , MH-ImageHeight(GameOverImg));\n"
" \n"
" gotxt=GetTextLine(60);\n"
" break;\n"
" \n"
" case 0: // если пориграли\n"
" BM.SetColor(255,0,0);\n"
" DrawImage GameOverImg,MW-ImageWidth(GameOverImg) , MH-ImageHeight(GameOverImg);\n\n"
" DrawText string gotxt,MW-TextWidth(gotxt)/2 , MH-TextHeight(gotxt)/2")
subst = "BM.Draw$1($2)$3"
result = regex.sub(subst, test_str)
if result:
print(result)