# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d+P)\b[^_]*_/$1_/gm;t' <<< "1080P,720P,480P,240P,_0987654321.mp4
720P,480P,_0987654321.mp4
480P,240P,_0987654321.mp4"