package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d+P)\b[^_]*_`)
var str = `1080P,720P,480P,240P,_0987654321.mp4
720P,480P,_0987654321.mp4
480P,240P,_0987654321.mp4`
var substitution = "$1_"
fmt.Println(re.ReplaceAllString(str, substitution))
}