use strict;
my $str = '1080P,720P,480P,240P,_0987654321.mp4
720P,480P,_0987654321.mp4
480P,240P,_0987654321.mp4';
my $regex = qr/\b(\d+P)\b[^_]*_/mp;
my $subst = '$1_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";