$re = '/\b(\d+P)\b[^_]*_/m';
$str = '1080P,720P,480P,240P,_0987654321.mp4
720P,480P,_0987654321.mp4
480P,240P,_0987654321.mp4';
$subst = "$1_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;