import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\s)(?:0|-?[1-9]\\d*|-?[1-9]\\d{0,2}(?:,\\d{3})+)(?=\\s|\\Z)";
final String string = "561,085\n"
+ "3,894,320\n"
+ "-59,099\n"
+ "1,000\n"
+ "1000\n"
+ "-1000\n"
+ "1\n"
+ "-1\n"
+ "0\n\n"
+ "-01\n"
+ "01393\n"
+ "01,300,00\n"
+ "-04,044";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}