const regex = /(?<=^|\s)(?:0|-?[1-9]\d*|-?[1-9]\d{0,2}(?:,\d{3})+)(?=\s|\Z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\s)(?:0|-?[1-9]\\d*|-?[1-9]\\d{0,2}(?:,\\d{3})+)(?=\\s|\\Z)', 'gm')
const str = `561,085
3,894,320
-59,099
1,000
1000
-1000
1
-1
0
-01
01393
01,300,00
-04,044`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}