import re
regex = re.compile(r"(?<=^|\s)(?:0|-?[1-9]\d*|-?[1-9]\d{0,2}(?:,\d{3})+)(?=\s|\Z)", flags=re.MULTILINE)
test_str = ("561,085\n"
"3,894,320\n"
"-59,099\n"
"1,000\n"
"1000\n"
"-1000\n"
"1\n"
"-1\n"
"0\n\n"
"-01\n"
"01393\n"
"01,300,00\n"
"-04,044")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")