$re = '/(?<=^|\s)(?:0|-?[1-9]\d*|-?[1-9]\d{0,2}(?:,\d{3})+)(?=\s|\Z)/m';
$str = '561,085
3,894,320
-59,099
1,000
1000
-1000
1
-1
0
-01
01393
01,300,00
-04,044';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);